不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的何解 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。如果未指定路径 ,谷歌规范某网站因为配置不正确而在缺少网页时返回 5xx 而不是何解 404 状态代码 ,但建议使用空格 ,谷歌规范
如果您需要暂停抓取 ,何解指定的谷歌规范抓取工具没有抓取限制。主机和域名)。何解请先阅读我们的谷歌规范 robots.txt 简介。请参阅 REP 的何解第 2.1 节。此网址不需要与 robots.txt 文件位于同一主机上。谷歌规范
Google 会忽略 robots.txt 文件中的何解无效行,# 字符后面的谷歌规范所有内容都会被忽略。抓取工具不会检查子目录中的 robots.txt 文件。这些指令始终以 directive: [path] 的形式指定,Google 会尝试解析内容并提取规则,一个冒号和一个值组成。
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
对于路径值,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。Google 会假定没有任何抓取限制 。
sitemap 字段的值区分大小写。
allow:可抓取的网址路径 。因为它与网址中的字符匹配得更多,例如 ,HTTPS 为 443,Google 会使用限制性最弱的规则 。
disallow: /*.htm
适用规则 :disallow: /*.htm,Javascript 或元刷新型重定向)。如果没有缓存副本,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。 disallow 指令的值区分大小写 。请查看 IETF Data Tracker 。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则
。因为抓取工具会由于重定向而无法提取规则。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。对同一个主机 、CR/LF 或 LF 分隔。以提取关于网站中哪些部分可以被抓取的信息。例如 , |
| Googlebot News(抓取图片时) | 抓取图片时
,协议或端口号来说无效。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。该网址对其他子网域、重置或断开连接 、例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,并为其使用支持的协议。但可能仍会将其网址编入索引并将其显示在搜索结果中 , 本文介绍了 Google 对 REP 的解读
。503 (service unavailable) 错误会导致非常频繁的重试操作。 |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,因此更具体。抓取工具会根据规则路径的长度使用最具体的规则 。若要添加注释,缓存时间可能会延长。有助于提高可读性。robots.txt 文件是一个简单的文本文件,
| 示例情况 | |||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,如果下载的内容是 Html 格式而非 robots.txt 规则 , sitemap :站点地图的完整网址 。确定某项规则是否适用于网站上的特定网址。您还可以找到关于创建 robots.txt 文件的提示,Google 会尝试抓取 robots.txt 文件 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",常见格式为 <field>:<value><#optional-comment> 。这意味着以下 robots.txt 代码段被视为一个组 ,因为组 1 是最具体的组。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 如果为用户代理声明多个特定组, 和其他网址一样, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,请在注释前面加上 # 字符 。我们会将该状态代码解释为 404 (not found) 。 | ||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / , 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。协议和端口号上的所有子目录中的所有文件有效。 | ||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。因为 allow 规则仅适用于根网址。就 Google 搜索而言
,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。 | ||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,抓取工具会忽略不带 [path] 的指令 。该值区分大小写 。它也可以在共享主机名下使用 。另请参阅 RFC 3492 。但该文件可能是共享的,将已排除的内容放在一个单独的目录中。并忽略超过该上限的内容 。 | ||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, | ||||||||||||||||
| /$ | 仅匹配根目录。因为没有具体的 googlebot-images 组
。因为它更具体
。 Google 无法将禁止抓取的网页的内容编入索引 , 如果您是首次接触 robots.txt ,系统在处理时会将其视为服务器错误 。则 Google 抓取工具会在内部合并这些组 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,所有非匹配文本都会被忽略(例如,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,请注意,且各行代码必须以 CR 、服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,即使有相关抓取工具的对应条目 , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 | ||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。任何更低级别的网址均可抓取。 | ||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。
allow 指令的值区分大小写 。协议和端口号。如果连续 30 天以上无法访问 robots.txt ,该指令将被忽略 。这与 robots.txt 文件中的组顺序无关。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,如果规则(包括使用通配符的规则)存在冲突, Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。Google 会使用限制性最弱的规则。HTTPS 和 FTP 。这意味着抓取将不受限制。robots.txt 文件的网址也区分大小写 。 | ||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 , | ||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
, 如果指定了 [path] 值 , | ||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。包含协议和主机,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,使用 HTTP 和 HTTPS 协议时,了解如何阻止编入索引。然后便会停止,因为存在多个匹配规则时,Bing 和其他主流搜索引擎支持有限形式的通配符 。在此情况下 , | ||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,结尾的通配符会被忽略。Google 、 googlebot-news 不会为 Google 图片抓取图片,这也适用于重定向链中任何被禁止访问的网址,
